Internal Service Issue - 8x8 Connect Portal Indonesia (ID) Region

Incident Report for 8x8 CPaaS

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 05:10 UTC

Investigating

We are currently investigating an internal service issue affecting the 8x8 Connect Portal. Users may experience difficulties accessing the dashboard at this time.

Our engineering team is actively working to resolve the issue, and we will provide further updates as soon as they become available.

We apologize for the inconvenience caused and appreciate your patience while we work on restoring normal service.

For any urgent assistance, please contact CPaaS Support at cpaas-support@8x8.com.
Posted Jun 09, 2026 - 01:48 UTC
This incident affected: Web Platform (8x8 Connect).