Internal Service Issue - 8x8 Connect Portal

Incident Report for 8x8 CPaaS

Resolved

This incident has been resolved.
Posted Jan 17, 2026 - 00:55 UTC

Investigating

We are currently investigating internal service errors affecting the Connect Portal. Users may experience difficulties logging in at this time. Our team is working to resolve the issue, and we will provide an update shortly.

We apologise for the inconvenience.
Please do reach out to cpaas-support@8x8.com for any further assistance.
Posted Jan 15, 2026 - 01:55 UTC
This incident affected: Web Platform (8x8 Connect).