Sign-Up Issue - Unable to Create New Accounts in 8x8 Connect

Incident Report for 8x8 CPaaS

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 03:34 UTC

Investigating

We are currently experiencing an issue with new account registrations in 8x8 Connect, where users are unable to successfully sign up for a new account. This issue affects only the account creation process and does not impact existing users or other platform features.

We sincerely apologize for any inconvenience this may cause and appreciate your patience as we work to resolve this as quickly as possible.

If you require further assistance, please reach out to cpaas-support@8x8.com
Posted Dec 03, 2025 - 01:43 UTC
This incident affected: Web Platform (8x8 Connect).